Archive for the ‘Uncategorized’ Category

Preparação – CCNA Voice

CCNA Voice CertificationEssa semana comecei os preparativos para a certificação CCNA Voice (ICOMM 640-461). Estou correndo atrás de todo o material de estudo e equipamentos para dar uma incrementada no Home Lab (postado neste link), que já decara está dando trabalho. Vou ter que escolher entre comprar os IP Phones com fonte PoE, ou comprar um Catalyst 3550 PoE.

Estava vendo o blue print da prova e batendo as informações no fórum do TechExams, e acabei comprando o livro CCNA Voice 640-461 Official Cert Guide, que é escrito pelo Jeremy Cioara. Pra quem teve como base de estudo para o CCNA os vídeos do CBT Nuggets, sabe que o Jemery tem uma didática espetacular, pois as explicações são simples e objetivas. Existe um pacote de CCNA Voice no CBT Nuggets, mas estou decidindo se vai entrar ou não no meu plano de estudos. O livro foi a primeira coisa que comprei, e creio que deve chegar nas próximas semanas (já que a porcaria dos Correios está de greve =/ )

De acordo com a galera que fez a prova, o ICOMM tem uma duração de 90 minutos, com 60-70 questões e uma nota de corte de 780. Nota de corte um pouco abaixo do CCNA, e com umas 10-20 questões a mais…o foda é que o tempo continua o mesmo. Sobre a nota de corte, acho que daqui pra frente as provas serão um pouco mais “fáceis” de passar, uma vez que o conteúdo é de uma carreira específica, e não de um nível Entry/Associate como é o CCNA Routing & Switching. Temos uma base de como funciona uma rede de pequeno/médio porte, e agora vamos focar somente em VoIP.

Bom, é isso aí. Vou buscar o material e montar o plano de estudos, e no próximo post mostro como será esta nova jornada.

Abraços!

Anúncios

Finalmente! Certificado CCNA!

ccna_largeFala!

Essas semanas fiquei ausente pois estava totalmente focado nos estudos. Essa “ausência” teve resultado, pois finalmente consegui minha certificação! A prova não estava difícil (ou eu que estudei demais?), e foi tudo muito tranquilo. Agora que deu tudo certo, estou me programando para tirar a CCNA Voice em até 6 meses. Nesse tempo vou levantar os equips para montar o Lab, e quais materiais são necessários para a prova.

Abraços!

Domingo praticamente perdido

Fala!

Hoje foi praticamente um dia perdido para os estudos. Tinha somente 5h de video-aulas para ver, e encerrar o curso do CBT Nuggets, e deu tudo errado. Tive diversos contratempos, e isso fez com que fechasse o dia faltando ainda 2h30m de video. A única coisa boa foi que dei uma arrumada no Lab, organizei os cabos e liguei os equipamentos de maneira decente.

Como os assuntos pendentes do CBT são Frame-Relay e IPv6 (dois assuntos que estou bem mais interado), vou ver os vídeos no trajeto para o trabalho e na hora do almoço, e se notar algo que mereça uma atenção maior, anoto o vídeo e o tempo para revisão no decorrer da semana. Amanhã vou preencher o cronograma que vem com o livro “31 Days Before Your CCNA Exam” e programar minhas próximas 4 semanas de estudo. Provavelmente por causa do curso de alemão e do treino para Exame de Faixa, vou ter que estudar o conteúdo de dois dias no final de semana, mas até aí tudo bem, porque já estou acostumado a usar de 8 a 10 horas de estudos nesses dois dias. Bom para estudar e praticar vários Labs.

Ah, só pra finalizar, entrei no site da VUE agora e meu exame está agendado para o dia 24 mesmo. aparentemente o Senac conseguiu a mesma data e horário que tinha agendado da primeira vez.

 

Abraços!

Prova agendada!

Depois de uma pequena ausência, tô passando pra postar que agendei a prova para o dia 24/09. A procura está tanta pra fazer a prova, que de ontem pra hoje sumiram no mínimo 05 dias =/

Tenho mais ou menos 33 dias para a prova, então a programação será a seguinte:

– Terminar entre sexta e sábado os vídeos do CBT Nuggets para ICND2;

– Revisão de todo o conteúdo com o livro 31 Days Before Your CCNA Exam

Para dar uma fixada ainda maior no que estou estudando, vou postar dia a dia o material com um pequeno LAB no Packet Tracer, e colocar as configs e topologias do meu Home Lab.

Bom, agora é aproveitar o máximo de tempo que tenho para revisar toda a matéria, e quando puder dar uma treinada no trabalho com os equipamentos =] .

Abração!

=]

Recuperação do arquivo VLAN.DAT

Antes do post deixa eu dar uma limpada por aqui que o pó tomou conta de tudo =)

Essa semana chegou um switch novo em uma unidade, e fiquei de realizar toda a configuração da criança. Pedi para o técnico da unidade colocar um notebook na rede e ligar o cabo USB console no switch, e acessei remotamente.

Antes de sair fuçando, aproveitei para ver se o Switch Core estava com o VTP Domain ativo, pois já ia poupar um tempo da configuração… mas infelizmente não estava. Como a entrega desse equipamento não é tão urgente, acabei explicando para um cara que começou esses dias como é meu checklist de configuração de equipamento. Acabou que alterei algumas configs no VTP Domain e fiz algumas VLANs. Para não ter que “desfazer” tudo para deixar o switch sem config, rodei os comandos write erasedelete flash:vlan.dat :

SW-CORE-CE#
SW-CORE-CE#
SW-CORE-CE#write erase
Erasing the nvram filesystem will remove all configuration files! Continue? [confirm]
[OK]
Erase of nvram: complete
SW-CORE-CE#
00:04:43: %SYS-7-NV_BLOCK_INIT: Initalized the geometry of nvram
SW-CORE-CE#
SW-CORE-CE#delete flash:vlan.dat
Delete filename [vlan.dat]?
Delete flash:vlan.dat? [confirm]
SW-CORE-CE#

Até aí tudo bem, até que eu li o seguinte hostname no qual executei os comandos: SW-CORE-CE

 

Entrei em pânico.

 

Garanto que se alguém olhasse pra mim nessa hora, com certeza ia soltar “Putz…que merda você fez pra estar com essa cara?”. Como ainda estava conectado no switch, minha primeira reação foi soltar um sh vlan para ver qual a situação das VLANs. Ao ver que elas ainda estavam lá, verifiquei a running-config. Ok, nada alterado, porém se o switch desligasse, iria subir sem nada, e a telefonia da empresa, junto com a comunicação iria para o espaço. Numa pesquisa rápida no Google, encontrei a solução no próprio site da Cisco, informando os passos necessários para recriar o vlan.dat. A questão é a seguinte: se o switch não reiniciou, quase tudo é recuperável. Então o que fiz em seguida foi criar uma VLAN qualquer para que as VLANs em execução junto com a nova, fossem criadas em um novo arquivo:

SW-CORE-CE#
SW-CORE-CE#conf t
Enter configuration commands, one per line. End with CNTL/Z.
SW-CORE-CE(config)#vlan 20
SW-CORE-CE(config-vlan)#name VLAN_TESTE
SW-CORE-CE(config-vlan)#exit
SW-CORE-CE(config)#exit
SW-CORE-CE#
00:37:42: %SYS-5-CONFIG_I: Configured from console by console
SW-CORE-CE#

Depois foi dar um dir flash: para ver se o arquivo havia sido criado:

SW-CORE-CE#dir flash:

Directory of flash:/

3 drwx 512 Feb 28 1993 21:15:55 -03:00 c3560-ipservicesk9-mz.122-52.SE
397 -rwx 796 Jun 21 2013 15:45:13 -03:00 vlan.dat
398 -rwx 24 Jun 21 2013 16:26:01 -03:00 private-config.text
399 -rwx 8740 Jun 21 2013 16:26:01 -03:00 config.text
400 -rwx 3096 Jun 21 2013 16:26:01 -03:00 multiple-fs

27998208 bytes total (12751360 bytes free)
scaceswcore#

Fiz isso com meu coração quase explodindo, mas ainda bem que deu certo. Depois foi só executar um copy run start e verificar se deu certo com um sh start.

Mais uma pra eu aprender a ver 5 vezes onde estou antes de sair dando comando a esmo.

 

Abraços!

 

Essa semana aprendi que…

Realmente… você só aprende algo, quando é na base da porrada, ou seja, na hora do “ou aprende, ou aprende”. Essas lições você leva por um bom tempo, e sempre rende ótimas histórias. Essa semana rolaram algumas, e aprendi coisas importantes como:

“Não é legal bloquear todas as portas do firewall, para depois sair desbloqueando as úteis. Nessa, você pode bloquear literalmente TODAS as portas, inclusive o seu acesso.”

Porra, eu tava todo felizão configurando meu novo firewall lá no trabalho, e pensei “pô, vou bloquear todos os acessos e sair liberando somente o necessário, aí fica mais fácil monitorar o tráfego”. Quando cliquei em “Apply” a página deu erro… pensei que tinha dado algum probleminha no navegador, mas logo em seguida percebi a cagada que tinha feito. restou-me apenas baixar a cabeça na mesa e pedir paciência a Deus, senão ia me atirar do segundo andar.

“Não redirecione todas as portas do modem para o Firewall, antes do mesmo estar 90% configurado”

Essa foi no mesmo dia. uns 20 minutos antes da galera ir embora (eu ia ficar até mais tarde para fuçar no firewall), pensei que seria correto alterar no modem as configurações das conexões TCP e UDP. Eu fiz a alteração para que todas as requisições fossem redirecionadas para o Firewall, e dei um OK sem pensar. 05 minutos depois a negada veio perguntar se a internet tinha dado problema de novo (Isso porque essa semana ficamos mais de 02 dias sem internet por culpa da Telefônica). Achei que era problema do ISP e deixei pra lá. Quando fui no CPD percebi que o a luz da internet estava ativa no modem, mas sem atividade…nisso lembrei que nenhuma máquina ainda estava configurada para passar pelo novo Proxy, já que eu estava esperando eles irem embora. A galera ganhou uns minutos de folga e eu fiquei dando risada que nem um retardado.

“Mesmo que o seu PC esteja passando por um Proxy, com navegação autenticada e funcionando, se o adaptador não estiver configurado para que o Gateway padrão seja o Firewall, ele não irá enviar e-mails.”

Essa eu acabei de aprender (isso mesmo! 02h15 da manhã!!!). Pô, o Firewall está integrado com o AD, navegando, registrando nos LOG’s, bloqueando as portas, entre outras, mas a porra do pc se recusava a enviar um simples e-mail. Mexi nas configurações do Firewall, liberei portas, IP’s, fiz o diabo… até que tive um insight e pensei “pô, será que é por causa do Default Gateway?” e foi na mosca! Na verdade seria na mosca, se não tivesse quebrando a cabeça por quase dois dias! O foda é que nesse meio tempo, fiz várias cagadas pensando que era culpa do Proxy.

Pra ter uma idéia, eu acabei zoneando o proxy, e o meu acesso remoto via LogMeIn no pc foi pras cucuias. Pra tentar um novo acesso, fiz toda a configuração para acesso via VPN, gerei um certificado, instalei o OpenVPN e mandei bala pra cima da minha estação. Daí foi questão de minutos (ou horas) pra tudo se acertar e achar o erro do POP e SMTP.

Garanto que isso vai ficar na minha memóriampor um bom tempo, e vai me ajudar muito daqui pra frente =)

Abraços!

Ahn?

Pô, fiz uma ligeira cagada e acabei perdendo meus posts anteriores…aqueles que escrevi com tanto carinho =( . Já que acabei zoneando tudo, mudei o visual pra não ficar tão triste…hahaha!

 

Abraços!